ficsit-cli-flake/shell.nix
D. Moonfire 9045893b1d
Some checks are pending
push / Build (push) Waiting to run
push / Lint (push) Waiting to run
push / Test (push) Waiting to run
chore: added it as an injectable flake
2024-10-21 22:42:38 -05:00

15 lines
345 B
Nix

{ system, pkgs, unstable, mfgames-project-setup }:
let
project-config = mfgames-project-setup.lib.mkConfig {
inherit system pkgs;
};
in
pkgs.mkShell {
buildInputs = project-config.packages;
shellHook = project-config.shellHook;
nativeBuildInputs = with pkgs.buildPackages; [
unstable.go_1_21
unstable.golangci-lint
];
}