dosage-unstable-flake/flake.nix

58 lines
1.7 KiB
Nix

{
description = "A comic strip downloader and archiver (unstable)";
inputs = {
nixpkgs.url = "https://flakehub.com/f/NixOS/nixpkgs/0.1.0.tar.gz";
flake-utils.url =
"https://flakehub.com/f/numtide/flake-utils/0.1.85.tar.gz";
};
outputs = { self, nixpkgs, flake-utils, ... }:
let pythonVersion = "python39";
in flake-utils.lib.eachDefaultSystem (system:
let
pkgs = nixpkgs.legacyPackages.${system};
lib = pkgs.lib;
python3Packages = pkgs.python3Packages;
fetchPypi = pkgs.fetchPypi;
in rec {
defaultPackage = python3Packages.buildPythonApplication rec {
pname = "dosage";
version = "3.1.dev104+g9e05fae304";
format = "pyproject";
src = pkgs.fetchFromGitHub {
owner = "webcomics";
repo = "dosage";
rev = "9163317abadcef0a562afaaf422828b56d006e20";
hash = "sha256-t5HxvXCFPNG5K1uDtfIxDo6JV921ywY1Eznj7GoSh44=";
};
nativeCheckInputs = with python3Packages; [
pytestCheckHook
pytest-xdist
responses
];
nativeBuildInputs = with python3Packages; [ setuptools-scm ];
propagatedBuildInputs = with python3Packages; [
colorama
imagesize
lxml
platformdirs
requests
];
meta = {
description = "A comic strip downloader and archiver";
homepage = "https://dosage.rocks/";
license = lib.licenses.mit;
maintainers = with lib.maintainers; [ dmoonfire ];
};
};
formatter = pkgs.alejandra;
});
}