mfgames-writing-js/flake.nix
D. Moonfire e3144df155 feat!: updating dependencies and restructuring project
- removed semantic release
- switched to a NixOS flake-based setup
  - using mfgames-project-setup-flake
- updated various underlying dependencies
- updated Node version
  - removed lerna
  - switched to npm workspaces
- updated the TypeScript version
  - basic logic for fixing various warnings and errors
- added the start of documentation
    chore: bringing various dependences and build systems up to date
2025-01-18 00:51:59 -06:00

34 lines
956 B
Nix

{
description =
"A framework for publishing Markdown files in a variety of formats.";
inputs = {
nixpkgs.url = "nixpkgs/nixos-24.11";
flake-utils.url = "github:numtide/flake-utils";
mfgames-project-setup.url = "git+https://src.mfgames.com/nixos-contrib/mfgames-project-setup-flake.git";
};
outputs = { self, nixpkgs, flake-utils, mfgames-project-setup, ... }:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = nixpkgs.legacyPackages.${system};
project-config = mfgames-project-setup.lib.mkConfig {
inherit system;
pkgs = nixpkgs.legacyPackages.${system};
};
in
{
devShell = pkgs.mkShell {
buildInputs = [
pkgs.nodejs_20
pkgs.nixfmt
pkgs.python314
pkgs.nodePackages.lerna
]
++ project-config.packages;
shellHook = project-config.shellHook;
};
});
}